Edit / Hide Selector Logic Odd

This topic contains 5 replies, has 2 voices, and was last updated by  Chazzer 6 years, 2 months ago.

Author Posts

Chazzer

Notice: this information was written when Microthemer version 2 was current. On Dec 26th, 2014 version 3 was released with a completely new interface. Some of the information may be redundant, but as much of the functionality remains the same in version 3 we haven't deleted this post.

I have an issue with the latest version in that the selector edit/hide logic seems odd.

Open Standard View :

In a Section, click Edit Selectors

Link changes to Hide Selectors (no selectors displayed)

Click again and Link changes to Edit Selectors ( Selectors displayed)

Click again and Link changes to Hide Selectors (no selectors displayed)

I’d expect Edit Selectors to reveal Selectors and link to change to Hide Selectors

Click Hide Selectors and link to change to change to Edit Selectors with selectors hidden.


Sebastian

Hey Chazzer,

Thanks for raising this issue. I’ve just had a play on my testing server and haven’t observed the odd behaviour you have outlined. It behaves as expected.

It sounds like it could be the result of a Javascript conflict on your WP install. Would it be possible for you to email me login details to the site you’re working on so that I can troubleshoot this further?

https://themeover.com/support/pre-sales-enquiries/

Many Thanks,

Sebastian


Chazzer

Sent you login details.


Sebastian

Hey,

I haven’t received your login details. Did you send them via my contact form?

https://themeover.com/support/pre-sales-enquiries/

Please could try sending them again?

Thanks,

Sebastian


Sebastian

Hey,

I’ve sorted this now. The following style rule in your style.css stylesheet was causing a problem:
html[xmlns] .clearfix {
display: block;
}

This CSS was overriding a CSS rule in Microthemer’s stylesheet (and causing a knock-on Javascript logic error):
.js .hidden-options {
display:none;
}

I have now changed this on your install of Microthemer to:
#tvr-ui .hidden-options {
display:none;
}

The next release of Microthemer will have this change too so you won’t need to redo the update when you upgrade.

Cheers,

Sebastian


Chazzer

Works a treat.

Thanks for your prompt assistance (as always) 🙂

You must login or register to reply to this topic.