403 Forbidden when Microthemer activated

This topic contains 5 replies, has 2 voices, and was last updated by  Sebastian 6 years, 5 months ago.

Author Posts

milkstudio

I get a 403 Forbidden You do not have access to index.php on this server when I activate Microthemer.

Not just for using Microthemer, but even accessing the frontend of the site.

I have to deactivate the plugin before I can view the site again.

I’ve tried disabling all other plugins, but this has not helped.


Sebastian

Hello, I haven’t come across a 403 with Microthemer before. Given the nature of the error, I think I would need a backup of your site to play with on my testing server. The problem may be specific to your server of course, but I can rule out a theme/plugin conflict by testing locally.

Would a backup be possible? If so, please send it to our support@ [this domain] email address. Perhaps via we transfer if it’s a large zip file.

Thanks!
Sebastian


milkstudio

Hi Sebastian and thank you for your reply.

I think you’re right when you say it’s server specific.

I installed Microthemer on another site on the same server = same problem.

Installed on a third site, different server, and no problem.

This being the case, I don’t think sending a copy of the site will help since it seems to be the same across sites on that server.

Do you know what, if any, server settings, need to be changed to allow Microthemer to work?

index.php is set to rw- r– r– (644) which I believe is quite standard, and the permissions are the same for index.php on the third site which did work correctly.


Sebastian

I think your web host might be better placed to see the picture more clearly with this particular problem. Would it be possible for you to open a support ticket with them? I’d be interested in their response. If not, let me know and I’ll scratch my head for a bit longer 🙂


milkstudio

Thanks Sebastian, I had some to and fro with the web host yesterday and they established it was mod_security on the server that was being triggered by Microthemer.

After changing settings / disabling some security stuff, they eventually put the mod_security to detection mode only and lo and behold it works.

So if anyone else has this issue in the future – that’s the best place to start.


Sebastian

Many thanks for sharing milkstudio!

You must login or register to reply to this topic.