[solved] An active PHP session was detected, Error in REST API

Author Posts


After update latest version the plugin causes the errors named in topic.
I rolled back to – the errors are gone.

edit: folloing message I received:
Uncaught Error: Class “Microthemer\Common” not found in /…/wp-content/plugins/microthemer/src/AssetAuth.php:216
Stack trace:
#0 /…/wp-includes/class-wp-hook.php(308): Microthemer\AssetAuth->addFrontendData()
#1 /…/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
#2 /…/wp-includes/plugin.php(517): WP_Hook->do_action()
#3 /…/wp-admin/admin-footer.php(78): do_action()
#4 /…/wp-admin/update.php(182): require_once(‘…’)
#5 {main}


Hey Mario,

Thanks a lot for reporting this. It should hopefully be fixed in version, which I’ve just released.

I introduced a PHP session in MT beta version as a last minute fix for another bug I noticed during my testing. I’ve never tried to use PHP sessions in a WordPress plugin before, and unfortunately hadn’t read up on the issues it can cause – such as problems with the REST API.

The latest version uses cookies, which is the recommended alternative.

I hope that helps. Please let me know if you still need assistance.



Sebastian, the latest version ( work as expected – no more errors.
Awesome support, thank you!


Great, thanks for confirming 🙂

You must login or register to reply to this topic.