Compatibility with Redis Object Cache and FPM Caching

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 2 months, 2 weeks ago.

Author Posts

dirtybirdindustries

Hello since moving over to spinupwp and using an NGINX / FPM based page cache along with the Redis Object Cache, Microthemer is difficult to use. It seems like the autosave makes problems. Sometimes I am making edits, the autosave is saving as I type and then the interface becomes unresponsive. This happens especially often when I am using the JS editor. As I’m editing the interface is saving every time I stop typing for a moment. Then eventually it just gets stuck on “saving settings…” and I get the following error in the console:

[Error] TypeError: null is not an object (evaluating ‘location.reload’)
refreshJS (frontend.js:1:10220)
success (deps.js:1:615563)
i (load-scripts.php:2:27368)
fireWith (load-scripts.php:2:28123)
x (load-scripts.php:4:22587)
c (load-scripts.php:4:26778)

Do you have any info regarding this compatibility?

Also, is there a way to disable this autosave as I type? So it only saves when I hit CMD+S

Details:

PHP 7.3

Redis Object Cache

Nginx FastCGI Cache

Thanks,
Dustin


Sebastian

Hey Dustin,

The JavaScript editor wasn’t meant to auto-save actually – that was a bug. But I’ve fixed it now in version 5.8.0.2. You can save the JS editor manually with Ctrl+S. The JS editor may have been causing particular problems because MT fully reloads the frontend page after JS save.

Do you have SCSS support enabled in Microthemer by any chance (Preferences > CSS/SCSS > Enable SCSS )?

Another user reported a problem with running SCSS on an NGINX server last week. I was able to replicate and then fix the issue on my NGINX server by disabling the following setting in nginx.conf:

open_file_cache off;
open_file_cache_errors off;

However, this didn’t work for Koen, and so I’m currently trying out a client-side SCSS compiler that will avoid reloading a non-cached CSS stylesheet, which was the root of the problem on my server. This should be ready for beta release early next week.

I’d be very grateful if you could let me know how you get on with the latest 5.8.0.2 release of Microthemer, with the nginx.conf setting update (if that applies to you).

Thanks,
Sebastian


dirtybirdindustries

open_file_cache off; and open_file_cache_errors off; were already disabled.

Updating to latest version seems to have worked briefly. I used it the other day and it was saving properly. Now I can’t access Microthemer at all. I get a blank screen in chrome and in safari I get an error: “cannot decode raw data”

I am running latest version of Microthemer 5.8.0.3 and WP 5.2.2

Tough to say what the problem is. I don’t see any errors in the logs.

Any ideas?


Sebastian

Ah, this might be due to gzipping. You may be able to fix this by going to the standalone Microthemer > preferences page and set “Gzip the Microthemer UI page for faster loading” to “No“.

I hope that helps.

Cheers,
Sebastian

You must login or register to reply to this topic.