CSS3 Styles Suddenly Stop Working in Internet Explorer

This topic contains 0 replies, has 1 voice, and was last updated by  Sebastian 7 years, 5 months ago.

Author Posts

Sebastian

Notice: this information was written when Microthemer version 2 was current. On Dec 26th, 2014 version 3 was released with a completely new interface. Some of the information may be redundant, but as much of the functionality remains the same in version 3 we haven't deleted this post.

Before Microthemer 1.1.4, the plugins/microthemer directory was given a different name for each update – e.g. plugins/microthemer1.1.2. We now realise that this was a bad idea. It meant that CSS3 styles (gradients, rounded corners, box-shadow) would break in Internet Explorer following an update (because the path to /plugins/microthemer/pie/PIE.php would become out-dated).

From Microthemer 1.1.4 onwards, the Microthemer directory will remain just “microthemer” to avoid this problem. However, this doesn’t help people who have a version of Microthemer prior to 1.1.4 – and updating to Microthemer 1.1.4 alone won’t solve the problem.

So here’s the manual fix:

Update Microthemer & Then Re-save Your Settings!

  1. Update Microthemer to version 1.1.4. See update instructions here (ensure that you check the “Do a Manual Update Check Now” checkbox on the preferences page to get the update immediately). If you don’t update Microthemer now you may end up having to redo this fix in future.
  2. Go to the Microthemer UI Page in WordPress
  3. Click the blue “Save” button in the right hand menu
  4. That’s it! The path to PIE.php should be updated.

You must login or register to reply to this topic.