Google Font is throwing Error 404

This topic contains 2 replies, has 2 voices, and was last updated by  Sebastian 4 years, 8 months ago.

Author Posts

devhouse

Hello,

I’m fairly new to Microthemer, but seem to be having issues using Google fonts. When I click the “Google Font…” option in the font drop down menu, it just brings up an Error 404 message for the website that I’m working on. Is this because I don’t have the Google Fonts installed? If so, how do I add new fonts to the library? Is there an easy way or do I need to add into theme-functions the old fashioned way..?


Sebastian

No, you shouldn’t have to do anything manual to get the Google fonts browser working in Microthemer. It sounds like something is up. Would you mind sending me access details for your site via our secure contact form so I can troubleshoot?

Thanks,
Sebastian


Sebastian

Thanks for providing access.

Strangely enough, it seems the process of disabling and then re-enabling your iThemes Security or Sucuri Security plugins solved the issue. One of them was blocking access to Microthemer’s fonts.php file, and possibly some other Microthemer functionality. I can’t say exactly which one because I disabled them both at the same time. And when I re-enabled them one by one, the problem was gone.

My best guess, which is a stab in the dark, is that the security plugin imposes limits on new plugins that it doesn’t impose on existing plugins. And when it was reactivated, it categorised Microthemer as an existing plugin.

Hopefully the issue is permanently solved. But if it reoccurs, I’m here to help.

Cheers,
Sebastian

You must login or register to reply to this topic.