Language-Switch has no "active" colour!

This topic contains 5 replies, has 2 voices, and was last updated by  Sebastian 2 weeks, 1 day ago.

Author Posts

aryser

Hi,
I try to assign an “active” colour to my language switch the same way like in works on navaigation bar. Unable do do so. Anybody can help on that?

https://ig-ten.webfolio.ch
Password: ruppdesign


Sebastian

Hey,

Could you clarify exactly what you’re trying to do? In the language dropdown menu, it only shows the letters for the non-active language. Which bit are you trying to style differently?

Cheers,
Sebastian


aryser

Hi Sebastian
I would like to “highlight” the choosen language the same way like I did the topic. Is that possible?


Sebastian

If Dutch was selected, and you just want to make the “D” stand out, you should be able to click the text and set the color property e.g.

.wpml-ls-display {
    color: red;
}

Just make sure you click exactly on the letter, so that you can target the innermost container element. If you set the color on an outer container element there is always the possibility that an inner element will override your color setting.

Does that help at all?


aryser

Hi Sebastian, that helped a lot. But now, the unselected languages dont switch colour on Mouse-Over. Whats that now?


Sebastian

Hey, did you paste that selector somewhere, rather than using MT? If so, try using MT. MT should find a selector that only targets the single element you clicked. The .wpml-ls-display class is used for the other languages too I see now (on closer inspection).

But if you want another copy and paste, try updating the selector to this:

ul:not(.sub-menu) .wpml-ls-display {
   color: black;
}

You must login or register to reply to this topic.