Microthemer interface not working on WP Ultimo multisite child site

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 3 weeks, 3 days ago.

Author Posts

LonelyViking

Hi,

I have an issue where Microthemer doesn’t work on a multisite child site after the site has had domain mapping applied to it.

For a little more clarity: The multisite works in a way where the child sites run on subdomains of the parent/main site. So that would look like child1.mainsite.com
Ultimo allows for domain mapping though so you can then map a domain to the child site’s frontend. Once that is done the backend still looks like child1.mainsite.com/wp-admin/ while the frontend is then mychilddomian.com

The problem now is that Microthemer is (understandably) expecting the subdomain but trying to load the custom mapped domain. The result is a “Security check failed” error.

The problem is that once a child site has domain mapping set up we can no longer use Microthemer for styling (although existing styling does still load on the frontend).

Any ideas how we can get around this?

Thanks!!

Error Screenshot


Sebastian

Hmm, that’s a tricky one. Microthemer loads the site frontend in an iframe. And in order for the browser to let it talk to the iframe, they must be running on the same domain. Am I right in thinking that if you set the frontend URL for MT to load to child1.mainsite.com via MT Preferences, Ultimo will automatically redirect to mychilddomian.com? If not, that could be a solution. Otherwise, your only option would be to disable the domain mapping temporarily while you work in MT. Not ideal I know.

Thanks,
Sebastian


LonelyViking

Setting the mapped domain in preferences sort of works 😀

Clicking the Microthemer link on the frontend doesn’t go to the correct place but if you manually enter the URL mychilddomian.com/wp-admin/admin.php?page=tvr-microthemer.php then it works.

That is a good enough solution for me 🙂

Thanks for your help!


Sebastian

Oh great, I’m glad you managed to find a way round 🙂

You must login or register to reply to this topic.