My Amazing Microthemer has stopped working :( [font changes not taking effect]

This topic contains 9 replies, has 2 voices, and was last updated by  Sebastian 5 years, 5 months ago.

Author Posts

Artmaestro

Hi Sebastian! Long time no speak because all this time your lovely Microthemer has been working flawlessly. Sadly it just stopped working. Specifically:
1. My WordPress version was upgraded to version WordPress 4.7.4 running Twenty Ten theme.
2. Since then, the Font changes I make to my site using Microthemer don’t take effect. However, all the Font changes I made using Microthemer BEFORE the WordPress update still work!
3. I tried using more than one of my custom uploaded fontfaces, just to make sure it wasn’t a font specific issue, and triple checked the spelling of the font names in the code, even using font names that in the past were successful and were showing up from the older Microthemer changes. Nothing I tried made the new Microthemer changes take effect.
4. I am testing the changes on my iphone as well as on my PC computers.
5. I tried updating my Microthemer plugin and that didn’t help.
6. I tried both Chrome and Firefox browsers.
7. WHAAAAAAAAwaaaaaaaaaaa – I want my Microthemer back!
Thanks Sebastian!
-Nicole


Artmaestro

Update: SOME of the old Microthemer fonts also now no longer working. The shadow effects still seem to be working. Fontwise anyway, my site looks a fright!


Artmaestro

Update 2: I tried restoring Microthemer to the way it was 5 days ago, and it made me lose more font changes, so that didn’t work.


Sebastian

Hey Nicole,

Nice to hear from you. Sorry it’s because MT isn’t functioning normally.

I’m happy to take to look. Which site is this affecting?

Cheers,
Sebastian


Artmaestro

Thanks Sebastian- it’s http://www.Nicole.bz


Sebastian

Wowza, that’s a lot of fonts you’re using. It’s probably slowing down your site, but perhaps you can live with that. And it’s not the cause of your current issue.

I see quotes are being escaped in the output, when they shouldn’t be. That basically means that you get lots of backslashes preceding single/double quotes: \’ (instead of just ). I’ll check if Microthemer needs to be updated to accommodate your server’s handling of quotes (by stripping them out). In the meantime, here’s all of your fonts without the pesky backslashes, which are invalidating your custom fonts. I did a find and replace to remove them all.

Paste the fonts into Microthemer (replacing the current custom fonts) and then save your settings again. Check if that fixes the font issue. But then refresh the page and do another save. Then refresh the page again. Did the back slashes come back?

Thanks,
Sebastian


Artmaestro

Thank you Sebastian! Your support is WONDERFUL.
OK, here’s what happened:
1. I copied and pasted your redone slashless code
2. I did the save and resave as best I could (in my freshly updated version of Microthemer I can’t seem to find the little Microthemer ‘save’ icon anymore – was that save icon done away with? To work around my being a dolt and not finding a save icon/menu command, in order to save I pretended to change something that I really didn’t change, bu typing in the same thing that was there before, and then hitting enter – does that trigger a save? If not, then I need to know how to save properly (would like to know that anyway)
3. SOME of the fonts did change to what they should be (in fact, I am where I thought I was when I first posted my first question to the forum yesterday – no custom font changes that I tried to create AFTER March (ie after WordPress update) (and even after Microthemer update) are working. See eg my last two posts at http://icreate.bz The font titles in these posts are defaulting to the Google Font rather than using the custom fonts macaronsregular and innocentsrough . The good news is that your fix of removing slashes did re-instate the Microthemer custom font changes done in March (ie, pre-update of WordPress/Microthemer have happily reappeared (hurray)! See eg 1871 Victor Hugo font for “Portfolio” in the sidebar. It seems so weird that no custom font changes that I tried to create AFTER March are working. See eg my last two posts at http://icreate.bz (the font titles in these posts are defaulting to the Google Font rather than using the custom fonts macaronsregular and innocentsrough .
4. What I did to trouble shoot: I checked my server to make sure the custom fonts were still on the server and I checked the Microthemer code to make sure the fonts were there also. I tried my best to resave (maybe that’s the problem – I can’t find the save icon/menu command), and I tried refreshing my browser (til my browser wanted to hurl my mouse at me but I dodged the flying mouse, my will to live to fix this problem is so strong!).
At least the site is looking better again – no one but me knows that the Google default font on the new posts isn’t the right font. I would like to be able to still use Microthemer for customizing fonts though – it is so cool!


Sebastian

Hey Nicole,

Could it be that you need to undo the history restore you did? By restoring the row in the table below the one that says ‘Settings restored’?

Also, are we talking about nicole.bz or icreate.bz? Are they equally affected by the same problem? Are they the same site in fact?

The following selector: Post >> Bench At Giverny Scarf Post
Applied the following font: CharcuterieCursive
To the following post title: “Bench at Giverny” Scarf at National Department Store

CharcuterieCursive appears to be sticking. Is that a Google font that you don’t want? Could you just change it via the ‘Bench At Giverny Scarf Post’ selector in your Posts folder?

The save button isn’t generally needed because MT auto-saves. We will communicate this more clearly in the next release. But in custom code view, where you add your custom fonts, you need to use the Ctrl+S keyboard shortcut. Or, click the save icon to the left of the editor.

Cheers,
Sebastian


Artmaestro

Hi Sebastian:
The slash thing and something about stepping backwards solved it!
For anyone having the same problem here’s the answers to the questions in your post – THANK YOU for your help:
1. Restoring to a prior set point made more fonts go away/slashes come back, so that restore wasn’t the fix in this situation.
2. Both nicole.bz and icreate.bz are the same site – just shortcuts to help you find examples. Sorry!
3. In the Bench at Giverny Scarf Post selector you mentioned as sticking, I changed CharcuterieCursive to SaboresScript – both are custom fonts (not Google fonts) – hopefully that’s not sticking anymore.
4. Your suggestions got me thinking though (rusty old brain), so I deleted the problematic 4 selectors, created a new folder, and redid all the selectors from scratch and …voila…worked! So your ideas of getting rid of the slashes along with a fresh start to the 4 problem selectors got my wonderful Microthemer back!
Problem solved! Have a WONDERFUL everything 🙂
Thanks for all your help!
-Nicole


Sebastian

Excellent news Nicole, thanks for rounding up.

Sebastian 🙂

You must login or register to reply to this topic.