Plugin doesn't work on SSL enabled sites. [Resolved – ensure site urls https]

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 6 years, 3 months ago.

Author Posts

digitalspirit

Hello,

I just purchased MicroThemer and am unable to use it as it simply won’t load.

Having done some trouble shooting, it more specifically won’t load when using https. Everything works if SSL is disabled for a page. However, disabling SSL to edit a page defeats the purpose of having it to begin with.

If you’re able to rectify the problem, great. If not, please go ahead and refund my purchase as I will not be disabling SSL so that I can use this plugin.

Below is the complete list of console errors I get:

[Warning] Invalid CSS property declaration at: @include (wpe-common.css, line 243)
[Warning] Invalid CSS property declaration at: * (spectrum.css, line 13)
[Warning] Invalid CSS property declaration at: * (spectrum.css, line 14)
[Warning] Unexpected CSS token: : (spectrum.css, line 161)
[Warning] Unexpected CSS token: : (spectrum.css, line 171)
[Warning] Unexpected CSS token: : (spectrum.css, line 189)
[Warning] Unexpected CSS token: : (spectrum.css, line 193)
[Warning] Unexpected CSS token: : (spectrum.css, line 197)
[Warning] Unexpected CSS token: : (spectrum.css, line 201)
[Warning] Unexpected CSS token: : (spectrum.css, line 205)
[Warning] Unexpected CSS token: : (spectrum.css, line 209)
[Warning] Invalid CSS property declaration at: * (spectrum.css, line 219)
[Warning] Invalid CSS property declaration at: * (spectrum.css, line 371)
[Warning] Invalid CSS property declaration at: * (spectrum.css, line 372)
[Warning] Invalid CSS property declaration at: * (spectrum.css, line 405)
[Warning] Unexpected CSS token: : (colorbox.css, line 61)
[Warning] Unexpected CSS token: : (mediaelementplayer.min.css, line 1)
[Warning] Unexpected CSS token: : (mediaelementplayer.min.css, line 1)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (styles.css.map, line 0)
[Log] JQMIGRATE: Migrate is installed, version 1.4.1 (load-scripts.php, line 9)
[Warning] [blocked] The page at about:blank was not allowed to display insecure content from http://digitalspirit.tech/.

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (tvr-microthemer.js.map, line 0)


Sebastian

Hi there,

I would certainly be happy to refund you if we can’t get to the bottom of this.

I suspect that the problem isn’t caused by SSL itself, but by having a mismatch of SSL on the frontend and non-SSL on the WordPress admin area, from which Microthemer runs. Microthemer loads the frontend preview in an iframe, and this causes problems if the frontend is SSL but the admin page that loads the iframe isn’t. Or if the reverse is true.

Browsers don’t like scenarios where there is a mixture of HTTP and HTTPS resources, and so I believe the only way to solve the issue to to remove the mismatch. In your case, this would mean switching to full site SSL on the admin area and frontend. I appreciate that you might have reasons for not wanting to go down that path. And if you also don’t want to disable SSL on the pages that currently have it, a refund may be the best course of action.

I hope I’ve explained things clearly. I’m happy to proceed however you like, and provide further support if necessary.

Cheers,
Sebastian


digitalspirit

Hi Sebastian,

I did find the solution while trying to work through this and Chrome giving me a mixed content error (The Safari output above didn’t) and maybe it will help someone else as well. That along with your mixed content suggestion had me looking at where it might be.

I just decided to look at my general settings and the urls both had http:// instead of https:// and changing those to be https:// fixed the issue.

So, I acknowledge that it’s my error. Maybe people can find this post as a fix.


Sebastian

Ah, excellent. I’m glad you managed to solve it. And thanks for sharing your solution!

You must login or register to reply to this topic.