Problem installing plugin [cannot create directories]

This topic contains 5 replies, has 3 voices, and was last updated by  Sebastian 7 years, 5 months ago.

Author Posts

jpyser

Hiya

I’ve already installed (and updated) previous versions of Microthemer on a few websites with no problems but I’ve been having issues getting the current version to install. Every time I try (whether via the WP plugins page or via FTP) I get this message which appears at the top of every admin page:

Warning: copy(/home/pcbloged/public_html/wp-content/micro-themes/PIE.php) [function.copy]: failed to open stream: No such file or directory in /home/pcbloged/public_html/wp-content/plugins/microthemer/tvr-microthemer.php on line 4274

Warning: copy(/home/pcbloged/public_html/wp-content/micro-themes/PIE.htc) [function.copy]: failed to open stream: No such file or directory in /home/pcbloged/public_html/wp-content/plugins/microthemer/tvr-microthemer.php on line 4274

Microthemer works even with this message (I can see that both files are present in the Microthemer folder) but the message won’t go away and using other plugins becomes an issue. Especially W3TC – every time I flush the cache, I get a blank page with nothing but those warning messages. I have tried deactivating all other plugins but the warnings and inability to correctly install Microthemer still remain.

Any help to solve this issue would be much appreciated!

Cheers

Jon


Abland

Hi, Jon,

It almost sounds like the upload directory path is incorrect. Is this happening on all sites or just this one?


jpyser

Hi Abland

Thanks for your reply. It’s happening on two sites at the moment but both have been set up by the same client so I am wondering whether it’s a permissions issue rather than anything else. I set the CHMOD of the wp-content folder (and sub-directories and files) to 0755 but that made no difference. That’s when I uploaded the folder manually via FTP – just in case it was a permissions problem. Still getting warning messages.

I don’t understand where the /micro-themes/ folder is supposed to be though. In my other installations of the plugin, I cannot see this folder anywhere in the folder structure. I’m now thinking that the command in /tvr-microthemer.php on line 4274 to set up a folder might be incorrect. I’m not that au fait with php but it looks like the directory value is empty earlier in the document (just showing ” ” where the directory name is listed).

However, I really don’t understand php so it could be anything…


Abland

From the errors it looks like you’re on a single site install, and the folder would be:

/wp-content/micro-themes/

Check to see if the folder “micro-themes” is there in wp-content, and if not manually create it. If the error goes away it’s a permissions issue in creating the folder.


jpyser

Aha…I have found the micro-themes folder in my other installations. It was a permissions issue – the server settings did not allow the creation of the micro-themes folder (or any other folder outside of the main WP plugins folder!) so the installation was borked when the plugin tried to set up the folder with the CSS/PIE files.

Created the folder and moved the two PIE files manually and there is now no warning message. Now to test and hope that it’s able to create the CSS files in that folder without having a hissy fit!

Cheers


Sebastian

I’m glad you managed get to the bottom of this. If you need help just shout.

@abland, thanks for stepping in. I missed this question yesterday.

You must login or register to reply to this topic.