Script error. (line 0)

This topic contains 10 replies, has 2 voices, and was last updated by  Sebastian 1 week, 3 days ago.

Author Posts

olleka

Hi
I have recently been having this error “Script error. (line 0)” and also some error about “uncaught error “hasClass”.
I suspected a plugin conflict. So I deleted the plugin. But the error is still there.
With the plugin active. I can not get MT to work at all. With the plugin inactive I still get the error but I can work in MT.
After deletion of plugin. Error is still there.
The plugin is “Next Post Manager for WordPress”
But the problem is there anyway so It might not be that plugin.

How can I best debug what is causing the error?

Regards
Olle


olleka

Hi again.
I have discovered thet it is something with this script.
<script src=”https://cdn.broadstreetads.com/init-2.min.js”></script>
<script>broadstreet.watch({ networkId: xxxx })</script>

It is a bit of pain if I can’t use it.


Sebastian

Hey Olleka,

I’m happy to help you troubleshoot this. Would you mind sending site access via our secure contact form?

Many thanks,
Sebastian


olleka

Ok thank you.
Site is http://olle.dyndns-ip.com/

I have tried several combinations. But “Next Post Manager for WordPress” makes MT totally unusable.

The other scripts is an an element in the Generate press Elements called Broadstreet Javascript.

If I disable all that MT works ok.

I think it is a little hard to use MT with other plugins. The site works ok but even if I have some errors in the console. But I can not work with MT. That is sad.

Maybe a setting that could override the javascript check?

Regards
Olle


Sebastian

Thanks for providing access Olle.

The broadstreet.watch error is probably worth fixing at some point, as it might affect other plugins that try to run scripts on the frontend of the site. However, it doesn’t seem to be causing any issues for MT. So I’ve followed your suggestion and added a new option to MT’s preferences:

Monitor general JavaScript errors on your site

I’ve set this to “No” on your site.

Are you OK to not use the “Next Post Manager for WordPress” plugin for a little while? That is clashing with Microthemer because is uses the same ACE code editor. In order to fix this, I will need to customise Microthemer’s ACE editor script. I’m happy to do that, but it will take some time to test properly, which I don’t have right now as I’m about to go away for a long weekend. I can sort it when I’m back though.

Cheers,
Sebastian


olleka

Thank you for checking.

If you can fix the problem with the ACE editor I’ll be very happy.

It makes it a bit harder for me to style the loaded posts But I think I can manage for a little while.

Regards
Olle


Sebastian

You got it!


olleka

Hi
How is it going 🙂

When do you think you will have a fix?

Regards
olle


Sebastian

Hey Olle,

I made two separate attempts to solve this by changing the namespace of the ACE editor, but concluded it’s not a workable solution. It has too many separate modules and references to update. So I think I need to approach this from another angle.

Really, plugins shouldn’t load their scripts on all WP admin pages. So you could ask the author of the plugin to limit where it loads the ACE library. I did a quick search for the plugin but couldn’t find it in the wordpress.org repository. Is it a premium plugin?

Cheers,
Sebastian


olleka

Ok, I’ll ask the developer. They are not so responsive I’m afraid.
The plugin is at https://wordpress.org/plugins/infinite-related-next-post-manager/
But I have the pro version from Envato.

Thanks


Sebastian

OK, I checked the plugin to see if anything could be done at the MT end. But I think the best solution would be for them to selectively load their JavaScript files only on the pages they should be on. Also, I’ve noticed a JavaScript error that gets generated on the frontend of the site – nothing to so with conflicting with Microthemer. It happens on all frontend pages, even when viewed normally (outside of Microthemer):

Uncaught ReferenceError: winpm_next_ajax_url is not defined

This issue also needs to be dealt with by the author.

Cheers,
Sebastian

You must login or register to reply to this topic.