Something's Wrong, Microthemer took more than 30 seconds…..

This topic contains 6 replies, has 2 voices, and was last updated by  Sebastian 5 years, 4 months ago.

Author Posts

StorypointUK

I have had this problem with earlier versions of MT and with your help, we’ve fixed it. Thing is, nothing has changed since I last used it, (except the latest update to MT, installed today) but now MT can’t load any pages from my website again. I’ve tried switching a few of my plugins off but it made no difference and this was never the problem in the past with my site. Can you give me any advice on this please Sebastian?
Thanks
Steve


Sebastian

Hi Steve,

Yes I’d be happy to troubleshoot this for you. Would you mind sending me login details for your site via our secure contact form?

Many thanks,
Sebastian


StorypointUK

Hi Sebastian
I have the details for you to login but I don’t think the link in your email was secure, as it just appeared in the forum!
Steve


Sebastian

Steve, my sincere apologies. I accidentally posted a link to this forum thread instead of the contact page. I’ve amended the link now. And I see from your other message that you found our secure contact yourself. Thanks for sending access details. I’ll take a look at your issue now.

Cheers,
Sebastian


Sebastian

Hey Steve,

I managed to figure out was wrong and have implemented a fix on your website. The issue was caused by a mixed content SSL warning. It was a slightly odd case though. Because as far as I could tell, the WordPress function home_url() was returning an HTTP url when it should have been returning an HTTPS url.

You have set the two URLs as HTTPS via the WordPress > General settings. And this is where the home_url() function looks. Mysterious. But I found a way to force https on the frontend when Microthemer is loaded over https, as this is always necessary to avoid these kind of mixed content warnings.

You should be fine now. If you notice any other issues just hola.

Thanks,
Sebastian


StorypointUK

Hi Sebastian

Thanks ever so much for your help on this. Without Microthemer I wouldn’t have a website, so keep up the excellent work!

Best

Steve


Sebastian

You’re welcome Steve. It’s great to hear that you’ve found Microthemer useful 🙂

You must login or register to reply to this topic.