The background colour change shows on the computer but not on the tablet

This topic contains 5 replies, has 2 voices, and was last updated by  Sebastian 6 years, 8 months ago.

Author Posts

elsie

I’m a complete novice at this, so you may have to dumb down the answer for me.

I changed the background color to be consistent across all pages. It shows on the laptop, but on the tablet, it’s white.

I tried going into the tablet/phone tab to change the background there, specifically, separately. That didn’t help.

Try this page: http://www.questforfulfillment.com/about-elsie/

It’s a Parallax Pro theme. What have I done wrong?

Thank you so much, Elsie


Sebastian

Hi Elsie,

You had the right idea. Occasionally mobile-specific styles in the theme can override global styles you set in Microthemer. However, this isn’t happening in your case. The difference between your laptop and tablet is actually due to being logged in to WordPress on your laptop. Unfortunately Microthemer picked up a class that only gets added to the tag if a user is logged in (.customize-support).

The selector wizard picked up the .customize-support class when it generated a selector for the page. But this selector doesn’t target anything on the page when non-logged in users access your site. The solution is to remove the .customize-support portion.

Navigate to your Background selector in your Pages folder. Then click it’s name in the top toolbar to reveal the selector editing options. In the CSS selector code textarea, change this:

body.customize-support div.site-container

To this:

body div.site-container

And then click the EDIT SELECTOR button.

I hope that helps. Please let me know if you need extra clarification.

Cheers,
Sebastian


elsie

Thank you so much for your help, Sebastian. I would never have figured that out on my own! And, it worked!

But when I go to the phone/tablet version, the menu button doesn’t seem to work. I checked the pages by going to the posts from the front page. But when I tried to go by way of the menu button, nothing!

How did I mess that up?

Thank you so much,
Leslie


Sebastian

Hi Leslie,

Are you referring to the responsive sandwich menu that only shows on smaller screens? And are you having difficulty using it on the site preview inside the Microthemer interface? If so I would need access to your admin area in order to check the issue. You can send login details via this secure contact form if you like: https://themeover.com/support/contact/


elsie

Sebastian, thank you. I just checked it again on the phone and the tablet and it’s working. Mystery.

But thanks for all your help! Really appreciate it.

Elsie


Sebastian

You’re welcome, let me know if you get stuck with anything else.

You must login or register to reply to this topic.