WordPress image path wrong [subdirectory installation]

This topic contains 7 replies, has 2 voices, and was last updated by  maryhellen 6 months, 1 week ago.

Author Posts

maryhellen

Hi, from few days background image in the header of my client’s site does not display.
I checked out and found the issue: the image path is incorrect. In the microthemer active css style is:
wp-content/uploads/2015/08/logo-arcobaleno96-tablet-ph.gif but right images
path instead is: /new/wp-content/uploads/2015/08/logo-arcobaleno96-tablet-ph.gif
Images that i’m refering to, should (as before correctly happens) display when page resize to tablet and phone size. You can see here a google cache copy when it worked
(try to resize):
http://webcache.googleusercontent.com/search?q=cache:7i1eF139YHcJ:www.arcobaleno96.org/+&cd=1&hl=it&ct=clnk&gl=it
Can you help me please? The directory “new” is the root directory of the wordpress installation. Site url is: arcobaleno96.org. Thanks.


maryhellen

Some more details: wordpress 4.7.5 and microthemer version 5.0.0.8 . Issue occurs on may 17 (we no made wordpress update neither microthemer plugin or new plugin installation before the issue, only enfold theme update). Thanks.


Sebastian

Hey,

Thanks for providing a detailed report. We did make a change to the way root relative paths are determined. This was a to fix a bug. But it seems to have a detrimental affect on sites like yours with WordPress installed in a sub-directory (but pages are served as if it was a regular root installation).

Would you mind providing me with login details for your site via this secure contact form? I think I might need to print some debug info on your Microthemer interface to fully understand how to solve this for you without breaking functionality for other users.

Thanks,
Sebastian


maryhellen

Hi, from few days background image in the header of my client’s site does not display again.
I checked out and found the image path is incorrect. In the microthemer active css style now is:
/newhttp://www.arcobaleno96.org/new/wp-content/uploads/2015/08/logo-arcobaleno96-phone.gif
but right images path instead is: /new/wp-content/uploads/2015/08/logo-arcobaleno96-tablet-ph.gif
Images that i’m refering to, should display when page resize to phone and tablet view. Thanks.


maryhellen

Some more details: WordPress 5.0 and Microthemer 5.5.1.0- Thanks.


Sebastian

Hey Mary,

Would you mind sending me access details for the affected site via our secure contact form so I can troubleshoot this?

Many thanks,
Sebastian


Sebastian

Thanks for sending access details. The new 5.5. version actually fixes this issue. The wrong URL paths were still left over from before, but I’ve corrected those now. And the issue shouldn’t happen next time you insert an image from your media library.


maryhellen

Thanks! Now everything works fine.

You must login or register to reply to this topic.