"2 Hours Ago" — History Time Off

This topic contains 4 replies, has 3 voices, and was last updated by  ddenev 4 years, 6 months ago.

Author Posts

Freelancer

…uh, no. More like 2 minutes ago. LOL.

😀

So, when I want to look at the last few steps I’ve just taken, in the ThemeOver ‘History’ section…it thinks I’m in another timezone. My site settings are correct — it’s in the right UTC. But ThemeOver thinks I’m a time traveler. 😀 HOW can I get ThemeOver to realize which time zone I’m in??

Thanks in advance for all and any help. 😀


Sebastian

Hey,

I’m so sorry for the slow reply, I just noticed your post. And I’ve now fixed the issue with the release of 5.1.6.1. MT was comparing blog time with server time when calculating time ago, instead of blog time with blog time.

Thanks,
Sebastian


ddenev

Hi, Sebastian

Just to let you know that I’m on 5.1.6.1 and the bug is still there. My local time is shown correctly in Settings/General.

I checked the code – the time is being set correctly (my current local time) but when retrieving it the unix_timestamp() MySQL function is used. This function returns time in UTC (https://dev.mysql.com/doc/refman/5.7/en/date-and-time-functions.html#function_unix-timestamp). So I guess this is the reason why I always get “2 hours ago” 🙂

I guess you have to do some magic with the get_date_from_gmt() function (https://wordpress.stackexchange.com/questions/94755/converting-timestamps-to-local-time-with-date-l18n).

Best regards,
Drago


Sebastian

Thanks for saving me some time! You’re right, I missed that unix_timestamp in the SQL. I’ll include this fix in the next release.

Cheers,
Sebastian


ddenev

No trouble, glad to help! 🙂

You must login or register to reply to this topic.