changes not saving – caching? [changes gone when logged out]

Tagged: ,

This topic contains 11 replies, has 4 voices, and was last updated by  Sebastian 6 years, 1 month ago.

Author Posts

martinrob

Hi

I am trying to change the colour of my blog post pages to look like the normal pages but it dosent seem to be saving, it shows it changing colour but when i log out and look at the site its gone.

http://www.socialwebservice.co.uk/ – normal page

http://www.socialwebservice.co.uk/bats-in-churches/ – blog page

If you need to take a look i have left you with a login as last time

Thanks in advance for all the help.


Sebastian

Hi Martin,

Whenever things look different to logged-in users vs non-logged in users, caching is normally the culprit. This can be due to caching plugins (e.g. wp supercache, w3 total cache, bwp minify) or server level caching systems like cloudflare, or evercahce (used by hosting company WP Engine, I discovered recently).

To ensure that non-logged in users see your latest changes (rather than an outdated cached version of your content) you need to flush/purge the cache.

  1. If you have a caching plugin installed, you should be to flush the cache via the plugin’s settings in your WordPress dashboard.
  2. If you have a server-level caching system active, you may be able to flush the cache via your web hosting control panel. Or you may need to contact your web host and ask them to disable server-level caching on your account and/or flush the cache for you.

Caching plugins/ server level systems can speed up your website. Web hosts love them because they save bandwidth and CPU processing power (money). But they can be troublesome for end users. I’m technical. But when working with caching systems, confusion is never far away. They are particularly confusing when you’re not expecting caching to be taking place, or haven’t come across the concept before.

Web hosts sometimes enable sever level caching on customer’s accounts by default. I think this has started happening more frequently than usual recently because we’ve had a surge of forum posts relating to caching recently.

If you don’t have any server level caching or caching plugins installed I’d be happy to take a look at your site if you can send login details via this secure contact form: https://themeover.com/support/contact/

Cheers,
Sebastian


Sebastian

Ah, I just read your comment about having already sent me login details. I’m in, and I see that you have a plugin called ‘Leverage Browser Caching Ninja’. But although active in WordPress, it isn’t enabled by the plugin’s own settings.

This points to server level caching. Or have you subsequently disabled the ninja caching plugin yourself after your initial post yesterday? (changes are showing for me when I’m logged out – I made one corner on the bats in churches post slightly rounded).


martinrob

I installed ninja the other day but i disabled it straight away as i need to finish off some changes and content ready for it to go to onto a live site.

Everything else seems to work fine just not changing the colour of the post page (which i will be adding more later today/tomorrow) i wanted the post pages to have the same colour as normal pages.

I am using shared hosting with heartinternet for now as looking at changing to a faster server built for wordpress, i dont think they have caching as i have never seen an option to clear chace in server setting.


Sebastian

Ah, apologies, I think I understand what you mean now. You were able to successfully add a grey background to the bats in churches post, but this doesn’t apply to all blog pages. As shown in this screenshot:

normal-vs-blog-pages

The reason for this is that your selector only targets that single blog page:

section#postloopud3b87 div.fix

The number in the id is specific to one post. I relaunched the selector wizard and found a more general selector (one that doesn’t contain a post-specific number):

section.single-post div.fix

I updated your selector and now the grey background does apply to all posts.

Could it be that when you logged out you viewed a different post, and because you were expecting the grey background to apply to all posts, you concluded that being logged out made the difference? (when in fact it was because the selector wasn’t broad enough)

Cheers,
Sebastian


martinrob

Hi Sebastian

That’s great and a massive thanks for the help once again your the man 🙂


itnw

also, fwiw, if anyone has WP hosting at BlowDaddy flushing the cache after most site changes is necessary…


Sebastian

Thanks for sharing!


Noosiekins

Hi,

I seem to be having the same problem. I’ve installed a caching plugin and performed a cache. I’ve also went to my server and deleted all the files in my cache folder under the WP Content folder. I’m trying to find out how to do a server cache from my host at Hostpapa. What else can I do to get this to work?

Thanks!


Sebastian

Hey,

Could you try temporarily disabling your caching plugin? If the problem goes away, you know that it is the caching plugin and not any server-level caching. If the problem doesn’t go away, it may be server-level caching. In which case your host should be able to help you clear the cache.

On rare occasions, things look different for non-logged in users because Microthemer has hooked into a class that is only added to the page for logged in users. Would you mind posting a link to your site so that I can rule out this possibility?

Many thanks,
Sebastian


Noosiekins

WPhelp.org helped me figured out that it was all because I forgot to turn off draft mode before logging out. Thanks for replying!


Sebastian

Aha, thanks for sharing your solution! We added the draft mode feature fairly recently, and I didn’t consider that possibility. I’ll know for next time 🙂

You must login or register to reply to this topic.