Google Font 404 [RESOLVED]

This topic contains 14 replies, has 2 voices, and was last updated by  Sebastian 7 years, 1 month ago.

Author Posts

Greggot

Hello,

I’ve been using Microthemer successfully but I’m working on a new site and for some reason when I try to customize a font and I click on the google font, the page in the window opening is a 404 error page of my website.

Does anyone have an idea why ?

Thx.


Sebastian

Hi Greggot, I’ve responded to your email about this requesting access to your site so that I can troubleshoot the issue.

Thanks,
Sebastian


Greggot

Hi Sebastian,

I’m sorry but I didn’t get your email ?


Sebastian

Hi Greg,

I’m sorry to hear that my communications haven’t been coming through.

I’ve emailed you again from a different email address this time, with the subject “Requesting access to your site”. Please either reply to the email or if you don’t receive it please send me some login details via my secure contact form: https://themeover.com/support/contact/

I will then look into the cause of your 404 error.

Many thanks,
Sebastian


Greggot

Hi Sebastian,

Did you get my email with the login details ?


Sebastian

Hey Greggot,

Yes I did receive your login details, thanks. I’m just looking into this now. Your server is returning a 404 on the following URL on your site:

/wp-content/plugins/microthemer/includes/fonts-api.php

(I’ve omitted the domain name just in case you don’t want me to post it).

The fonts-api.php file should exist alongside all of the other files Microthemer needs in order to load. And I can actually confirm that this file does definitely exist by browsing the plugin files via the Extensions > Editor page in WordPress. This points to an issue with your .htaccess file or a 3rd party plugin. Your .htaccess file should have some code that looks like this:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

This next line is needed so that your server will still load non-WordPress URLs, like regular PHP files:

RewriteCond %{REQUEST_FILENAME} !-f

If that’s missing or has been commented out with a # at the beginning of the line, this would explain the problem. If not, my next guess would be your ‘.html on PAGES’ plugin which must do some URL rewriting in order to add .html to your pages. This plugin might have some compatibility issues with Microthemer. I haven’t tried disabling it as I thought it would be best to get your permission first.

Please let me know if any of this stuff is helpful. If not I will investigate further.

Cheers!
Sebastian


Greggot

Hi Sebastian,

I’ve deactivated all my plugins except Beaver Builder and the 404 error remains.

On another domain on the same server, I have the same problem. And on another one, same server, it’s working fine.

I’ve taken a look a the htaccess and it seems ok.


Sebastian

Thanks for that. To rule out any of the code you pasted from your .htaccess file, could you make a backup of your .htaccess file and then delete it or rename it on your server. If the fonts-api.php file still returns a 404 when you refresh your browser then we will know that nothing in your .htacess file is the cause. If the file loads properly on the other hand, we will know for sure that something in the .htacess file is the cause. The next step would then be to remove pieces of the code in the .htaccess file until we can isolate the right line (or try to make educated guesses, which is only sometimes quicker 🙂

Cheers,
Sebastian


Greggot

So I copied the htaccess to another folder to have a backup, deleted it and refreshed. Now I have a database error and can’t connect to the website or admin anymore.

Any idea to get it back ?


Greggot

Ok, I got it back ! I tried a different approach. I kept the htaccess file but emptied the content.

No luck, the 404 error is still there.


Sebastian

OK, so that rules out the .htaccess file. Interestingly, I can load these files directly on your server:

  1. /wp-content/plugins/microthemer/documentation/changelog.txt
  2. /wp-content/plugins/microthemer/css/styles.css
  3. /wp-content/plugins/microthemer/js/fonts.js
  4. /wp-content/plugins/microthemer/includes/place-holder2.html

But your server will not load any PHP files directly, e.g:

  1. /wp-content/plugins/microthemer/includes/fonts-api.php
  2. /wp-content/plugins/microthemer/tvr-microthemer.php

This could be caused by a php.ini file if the .htaccess file (or another .htaccess file) isn’t at play. You may need to raise this issue with your web host. If you post a link to this forum thread in your message to them it should help them isolate the cause. Does that sound like a reasonable option?

Cheers,
Sebastian


Greggot

Ok, I sent them the link to our thread. They will be able to read it without creating an account ?


Sebastian

Yep, the forum is open 🙂


Greggot

Just to let you know it’s all good now. It was a htaccess problem but in another folder /wp-content/.htaccess, here was the content :

<Files *.php>
deny from all
</Files>

<Files fonts-api.php>
allow from all
</Files>

I simply changed deny to allow and it works now.

Thank you for your help.

Microthemer is really great !


Sebastian

Awesome news, I’m glad we got there in the end!

Cheers,
Sebastian

You must login or register to reply to this topic.