how to change BG color opacity to transparent?

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 7 years ago.

Author Posts

joehark

I’d like to change a navbar bg color so it is transparent. How can I do that?


Sebastian

Hi Joe,

I assume you’re talking about the green menu on this website: http://aisvg.com/

  1. Once you’ve created a selector for the navbar (I recommend double-clicking near the right edge so that you don’t target the links contained within the menu), go to the Background property group.
  2. Launch Microthemer’s color picker by clicking the background color field.
  3. Drag the opacity slider in the color picker down from 1 to 0.
  4. That should do it!

joehark

Yes – thanks. For the moment – probably until this afternnon – I’m postponing work on that site. I made a maddening discovery abot something that others may encounter (no fault of Themeover).

The owner of the site bought a subscription to Sucuri.com – a service that detects and clean infections and the monitors the site on a daily schedule for hacks. But – and I did not know this until after many hours of going crazy – they cached the site. Changes I made were not happening.

I even turned off Themeover in an attempt to isolate the cause of the problem. I have some code experience – especially in CSS – and use the Chrome Browser’s “Inspect Element” to figure out where something is controlled. I also have a good little free code editor (AlleyCode) to make small changes.

But nothing I changed was showing up on the site.

Out of desperation I made a full backup of the site and downloaded it. Then I deleted the existing theme’s style.css file.

Nothing happened. It did not break the site as it should have. Yet Inspect Element still showed it was serving that file.

Fortunately I have an activity tracker that logs every action in WrodPress. I was shocked to find that Sucuri was calling home with every entry and replacing my attempted edits with the style.css from their cache – thus wiping out my changes – even though there is nothing in the WordPress Dashboard to reveal that this is happening. There is no reporting of these events so neither I nor the site owner had any idea it was happening.

But thanks to the activity monitor I was able to discover it and get Sucuri to tell us how to disable their service while editing.

I hope this explanation keeps someone else from wasting many frustrating hours.


Sebastian

Thanks for sharing Joe! This general issue of caching has started coming up in the forum far more frequently than it used to. Case studies are always welcome.

You must login or register to reply to this topic.