How to prevent jumping to first element that matches selector?

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 4 weeks ago.

Author Posts

Norm6257

Hi,

Scenario: I’m in MT viewing an element on a long page, about 2/3 of the way down. I want to see the effects of modifying the css for the selector and see what it looks like on that element.

Behavior: When I edit a selector rule in MT, it then jumps the viewed page to the first element that matches the rule, which could be at the very top of the page. I then have to scroll the page all the way down again to try and find the element that I want to observe.

Question: Is there a way to stop MT from automatically scrolling to the first element that matches the selector? I’ve looked in preferences, but I don’t see an option.

Thanks,
-Norm


Sebastian

Hey Norm,

If turning off targeting mode off (bottom right) or element highlighting (top toolbar) doesn’t disable Microthemer’s scrolling to elements, then it should, and I will update MT accordingly.

Cheers,
Sebastian


Norm6257

Thanks Sebastian. I have both highlighting and targeting disabled and it still seems to jump.

Question: Could you make this a separate preferences setting? There are many times when I’m inspecting a page and I just want to stay right where I’m at. Even when I turn on targeting, my preference is to stay where I’m at rather than become disoriented when the page jumps to an area that I’m not focusing on.

-Norm


Sebastian

Hey Norm,

Thanks for your suggestion. I’ve just added a new preference for turning off auto-scroll in version 7.1.5.9.

Set “Auto-scroll to the current element, if out of view” to “No“.

Let me know how you get on with it switched off. If there are times when you miss it, I could look a less binary solution – adding logic to refine when it should or shouldn’t happen. It would also be good to know if you don’t miss it at all.

Cheers!
Sebastian

You must login or register to reply to this topic.