Memory Limit error upon activation?

This topic contains 6 replies, has 3 voices, and was last updated by  La4_sCSgD_BGU2c8gq_4GtI 4 years, 10 months ago.

Author Posts

La4_sCSgD_BGU2c8gq_4GtI

Hi, just purchased ‘Developer’ license, upon activation am getting mssg:

Sorry, Microthemer requires a memory limit of 16MB or higher to run. Your memory limit is less than this. Deactivate Microthemer to remove this message.

I am keeping my config data in custom file above public_html and including file into wp-config in public_html

Our current wp-config looks like this:

<?php
define('WP_CACHE', true); // Added by WP Rocket
/**
 * The base configurations of the WordPress.
 *
 * @package WordPress
 */

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
	define('ABSPATH', dirname(__FILE__) . '/');
	require_once(ABSPATH . '../XXXXXXX/XXXXXX.php');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

In my custom config file, I have set

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

There is no memory issue, and adding the above defines directly to wp-config resolves the error message…

We’d rather not have to bring these defines back to the standard location (we try to keep as much as possible out of wp-config) – please advise if some workaround is possible =)

Kind Regards, Max


Abland

Hi, Max,

Have your tried including your file higher up?

<?php
define('WP_CACHE', true); // Added by WP Rocket
/**
 * The base configurations of the WordPress.
 *
 * @package WordPress
 */

require_once( '../../XXXXXXX/XXXXXX.php'); // Move include up here

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
	define('ABSPATH', dirname(__FILE__) . '/');	

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

La4_sCSgD_BGU2c8gq_4GtI

hey, good point =)

I think that should work if you do… will try it later tonight


La4_sCSgD_BGU2c8gq_4GtI

worked! Thanks =)

ps. submitted contact form re. issue w/ license validation using .network email…


Sebastian

Awesome tech support Abland. Thanks for pitching in!

La4 – I’ve responded to your email about validation problems. It sounds like your server might be blocking Microthemer’s outgoing connection to themeover.com.

Cheers,
Sebastian


Abland

My pleasure! And this is why I enjoy the forums – always learning. Securing the wp-config.php core info above the public_html is so simple and direct … and it never occurred to me 🙂

Thanks, Max, for sharing that.


La4_sCSgD_BGU2c8gq_4GtI

Cheers Abland =)

‘simple and direct’ is the way I like to play it!
(except of course when I’m also being tricky and circuitous –> above are the basics, yet there may be a little more to my setup … )

You must login or register to reply to this topic.