Microthemer opening up Beaver Builder in edit mode

This topic contains 17 replies, has 4 voices, and was last updated by  Sebastian 4 years, 8 months ago.

Author Posts

dianemk

Hi, as above. Sometimes after publishing a page in BB, if I go into MT it goes back into edit mode in BB and I have to publish the page again to get out of it. No real problem but a bug perhaps. Thanks, Diane


Abland

Hi, Diane,

In the WordPress admin:
Microthemer > Preferences > General Tab

Under the entry:
“Frontend preview URL Microthemer should load”

does the URL end in “?fl_builder” (no quotes)? Remove that part if it does.

** As a follow up, if that part is there and you remove it, does it return when you publish in Beaver Builder again?


dianemk

Hi Abland,
I removed ?fl_builder
Published in BB
Went into MT and the BB edit mode opened again
I checked and ?fl_builder is back in the MT settings

It’s no big deal as I can just publish in BB when I open MT but thought I’d let you know as looks like a bug. Thanks


Sebastian

Hi guys,

@dianemk – yes that shouldn’t be happening.

@abland – good catch. Microthemer is stripping out the ?fl_builder parameter from the View > Change site preview URL field after a BB publish, but not the field in the Preferences. And that value can load BB again when it shouldn’t. I’ll get a fix out soon!

Cheers,
Sebastian


zholy9

OK … well I second this problem. I wrote to Beaver Builder first regards this since I have the same issue after I press CLEAR CACHE on WP-Rocket as well. That’s what they started with in first place and now try to reproduce the problem. MicroThemer was my second guess (which I suggested to BB team as well) … still waiting for their reply.

At the beginning, it was kind of OK … but now I’m really frustrated with this always EDIT ON after opening MT or pressing clear cache on WProcket.

Sebastian, if you think the FIX you’ve described above will sort this out : “Oh boy, please don’t wait with the fix for too long!” … I have this “bug” on all of my sites.


Sebastian

Sure thing Zdenek. I appreciate this is a nuisance for everyone using BB. And I’ll get it fixed on Monday or Tuesday. I’m currently testing the new transition properties and might be able to release them at the same time.

Cheers,
Sebastian


Sebastian

Hi guys,

I’ve changed the behaviour so that Microthemer doesn’t auto-load Beaver Builder when using the Microthemer shortcut in the top WP admin bar, even from a page that was being edited with Beaver Builder. Was that the navigation flow you guys were using?

This fix may not fully get to the bottom of the problem, I wonder if you could try it and see? Here is the download, I haven’t released it as a general release yet: http://themeover.com/misc/microthemer.zip?v=3

As a bonus, this pre-release includes the new transition properties (and a fix for the Google fonts issue you flagged Zdenek).

Cheers,
Sebastian


zholy9

Hello … can confirm on a new WP install that all seems to be sorted. MT doesn’t open in edit mode, heading seems to be working nicely.

Was a bit scared to try on a live website, as wasn’t sure if after deleting MT (since I can’t install over it) my CSS styling will stay. Could you explain a bit on this ?

Thank you in advance.


Sebastian

Hey,

Microthemer will never delete any settings when you uninstall Microthemer – unless you explicitly set this to happen via the Preferences > Inactive tab (see image below). This option is set to “No” by default. So you can safely uninstall MT without losing styles.

MT doesn't delete data on uninstall by default


zholy9

Cool … thanks so much for clarifying this. Will update on the life sites and test there as well. Thx


dianemk

Brilliant, thanks for this.

Zdenek I’ll let you be the guinea pig on the live sites 🙂 I’d be grateful if you post back so that I can install the update on my live sites. Thanks


Sebastian

Zdenek, thanks for reporting the issue with the pre-release where the clear icon triggered an error. I’ve released a fix for that now. See here: http://themeover.com/misc/microthemer.zip?v=3

Cheers,
Sebastian


zholy9

Another one for you Sebastian … 🙂

https://www.useloom.com/share/9a0e68072104439485a5e076042dd337


Sebastian

Thanks Zdenek, I’ve just updated the pre-release with some other fixes too. I wasn’t actually able to replicate your error, but I could see what code it relates to and made an adjustment. Were you getting that error continuously? If the latest update doesn’t sort it, please could you send access details for the site via our secure contact form?

Thanks,
Sebastian


zholy9

Well… I just asume, that the link for download is the same (as before) …right ?


Sebastian

Yes, that’s right!


zholy9

Working on it since morning (just simple CSS) and so far good 🙂


Sebastian

Excellent. Thanks for feedback.

You must login or register to reply to this topic.