Microthemer stops working after WP 5.6 update

This topic contains 6 replies, has 2 voices, and was last updated by  DirkD 2 months, 2 weeks ago.

Author Posts

DirkD

Anyone else experienced problems after updating to WP 5.6 ?
I use latest version of Microthemer : 6.3.4.7

Targeting does not work anymore.
In the right above corner I first notice this message “Loading WordPress site …”
After about 30 seconds it then says “Something’s wrong…”

Before WP 5.6 I did not have any problems.


Sebastian

UPDATE – simply update Microthemer to version 6.3.4.9 or later to fix this. It is not necessary to install the jQuery migrate plugin, but it is still advisable to fix potential issues with other plugins (which could otherwise interfere with Microthemer, or the normal functioning of your site in general).

Thanks for reporting this. WordPress 5.6 includes a new jQuery library, which is not backwards compatible. I will need some time to update Microthemer so it works with the new version. To give developers time to work on this, WordPress have released a plugin that reverts jQuery to the previous version:

https://wordpress.org/plugins/enable-jquery-migrate-helper/

Instructions

  1. Install and activate the jQuery migrate plugin (search for “Enable jQuery Migrate Helper”)
  2. Go to Tools > jQuery Migrate
  3. Set jQuery version to Legacy 1.12.4-wp
  4. Save settings

Thanks,
Sebastian


DirkD

Hi Sebastian,

Thanks for the interesting update on this issue. I will check out your tips.
Take your time. I totally understand you will need it 🙂

About the slider/menu… I’m using Oxygen in combination with the Oxyninja Core and WooCore framework.
It’s pretty much ‘out of the box’. It seems I have to dig deeper into that as well :-/


Sebastian

OK, Microthemer 6.3.4.8 fixes all issues now, including the issue with the CSS property fields. You no longer need to use the jQuery Migrate plugin (which I’ve deactivated on the site you provided access to).

The lingering issue was because WordPress 5.6 also updated it’s jQueryUI library. I’ve solved the problem for now by reverting to the pre WP 5.6 version of jQuery – just for Microthemer pages. This is a temporary fix to buy more time to update and test the code base properly.

Thanks for your patience!

Sebastian


DirkD

Hi Sebastian,

Ehm, I hope I didn’t overlook something… but I’m still having the same issues.
Logged out and back in, but there’s no difference …
I do see the updated version number.


Sebastian

OK, I was able to replicate the “Loading WordPress site …” issue, but only occasionally (1 in 3), hence I missed it at first.

I’ve reactivated the jQuery migrate plugin on your site. It occurred to me that WP 5.6 might be breaking other plugins in various ways, and that this could be having an indirect affect on Microthemer. I’ve now refreshed your MT interface over 10 times without encountering the “Something’s wrong…” error. But could you check at your end please? Network speed and resource loading order might be a factor in why the error is intermittent.

My advice for everyone is to keep the jQuery migrate plugin active for the next month or two. Because this WP 5.6 update is bound to break a ton of plugins in ways that aren’t necessarily in-your-face obvious.


DirkD

Hi Sebastian,
With the jQuery migrate plugin active I don’t experience issues anymore in all my browsers, so all fine for now.
For a moment I was really considering to roll back to WP 5.5.3 (because of other security risks that seem to exist) but I still have 5 other (non Oxygen) websites running (without MT). They are all upgraded to 5.6 without any issues. Maybe I could try to install MT on some of them too, just to see if these issues come up or not. I’m going to try that later.
Can’t thank you enough for the great communication and follow-ups.

You must login or register to reply to this topic.