MT Prefs problem [preferences selected and will not change]

This topic contains 10 replies, has 3 voices, and was last updated by  Sebastian 5 years, 7 months ago.

Author Posts

mtmfx

In the MT preferences “Add a Microthemer shortcut to the WP admin bar” and “Include admin bar shortcut as a top level link” both YES & NO are selected. I am trying to select NO to both of them. I have cleared the cache and turned off plugins and nothing changes. I am running the latest WP and MT 4.9.7.6.


mtmfx

Here is a screenshot

Microthemer preferences


Sebastian

Hmm, I haven’t seen this issue before. Would you minding sending me login details to your site via this secure contact form? https://themeover.com/support/contact/

Or alternatively, send me a screenshot of the error console (Right click your page, choose inspect, go to the console tab, then refresh the MT interface and look for red text that appears in the console).

Cheers,
Sebastian


mtmfx

Hi,
Sorry for the delay but your email was caught in my spam catcher. Here is a screenshot. http://imgur.com/sfquY80

Error console


Sebastian

Ah, unfortunately that doesn’t help me. I think I would need access to your interface in order to troubleshoot this. But first, you could try disabling all other plugins to see if the problem goes away. If it does, you could try enabling them one by one until the error comes back.

Cheers,
Sebastian


Sebastian

Hey,

Did you have any luck solving this by disabling plugins? Another customer has reported the same issue. We’re keen to roll out a fix for this. But we’ve so far been unable to replicate the problem on our testing server.

Many thanks,
Sebastian


mtmfx

Hi,

Sorry for the delay I am super busy. I am having the same problem on my local version of this site. I went through each plugin one by one and deactivated, cleared the cache and loaded MT prefs. The problem did not go away. I switched the theme to twenty sixteen, cleared the cache and no luck. So to recap using WordPress 4.7.2, theme twenty sixteen with no plugins activated but Microthemer and I still have the problem. The problem most likely is with WordPress don’t you think? Screenshots

Michael


Sebastian

That’s interesting Michael. That does help narrow it down. On my testing server, I don’t see any problems with MT on the latest version 4.7.2 of WordPress. With fresh installs, or updating from a previous version. So I wonder if server settings might be causal in this. Do you know what version of PHP you’re using?

Thanks for helping out when you’re super busy BTW. If you don’t have time to reply now, I might be able to research this by myself.

Cheers,
Sebastian


Abland

Hey, Fellas,

I have the same issue in the preferences where both radios are selected but all others work fine. In “includes/tvr-microthemer-preferences.php” I see both options are the only ones coded with default values so when I commented out the defaults and the ending comma on the preceding lines it worked fine.

Lines are 80 and 85.

Still unsure if there’s a cause outside of that, though.


Sebastian

@abland. You hero!

@michael I really dropped the ball on this. Despite you’re clear description of the problem, with an added screenshot, I was blindly sticking to an assumption that ALL of your preferences were set to ‘yes’ and ‘no’. I had temporarily caused such behaviour while working on a new CSS import feature around the same time you initially reported this. I think I merged the problems in my mind, and so was testing the wrong MT preferences. But following Abland’s fix, I was able to replicate the problem and fix.

There was some redundant logic logic in the plugin. I’ve removed this now and released version 4.9.7.7. You can auto-upgrade via your WP dashboard.

Thank you so much for saving the day yet again Abland.

Have a great day guys!
Sebastian


Sebastian

Further – version 4.9.7.8 finishes the job! The admin bar was still displays on ‘No’ despite our fix to the presentation layer. Getting there guys 🙂

You must login or register to reply to this topic.