Slow on my wordpress

This topic contains 2 replies, has 2 voices, and was last updated by  Sebastian 7 years, 5 months ago.

Author Posts

roelanb

Notice: this information was written when Microthemer version 2 was current. On Dec 26th, 2014 version 3 was released with a completely new interface. Some of the information may be redundant, but as much of the functionality remains the same in version 3 we haven't deleted this post.

Hi,

I downloaded Microthemers and installed it. I’m running wordpress 3.3.1 on a windows server.

Working with microthemers is however very slow. ANy ideas on how to speed this up ?


Sebastian

Hi there,

I’m sorry to hear that Microthemer is running slowly on your install. I will do my best to get this resolved for you.

Please could you be a little more specific about what is running slowly. For instance:

Do you find the main Microthemer UI page takes a long time to load initially?
Or does it take a long time to save your settings?
Or does the interface run slowly when you do things like add a new selector?
Or is it all of the above?
Finally, what internet browser are you using? Microthemer is slower when used with Internet Explorer. Firefox, Chrome and Safari are much quicker.

Many Thanks


Sebastian

I have now fixed this for you Bart.

This problem was caused by an error in the condition that checks for an SSL url. It was returning a false positive on your windows server. Because your server is not set up for SSL, it was stalling when trying to include javascript and CSS files using the https prefix. This problem will be fixed in all versions of Microthemer FOLLOWING 1.0.7. The manual fix was this:

1. Log into WordPress
2. Go to plugins page
3. Click ‘Edit’ link next to “Microthemer” in the table on the right
4. Click the “microthemer/get-dir-paths.inc.php” link on the right
5. Change this code:
// allow for SSL on certain pages too
$wp_content_url = (empty($_SERVER['HTTPS'])) ? $wp_content_url : str_replace("http://", "https://", $wp_content_url);

6. To this code:
// allow for SSL on certain pages too
$wp_content_url = (empty($_SERVER['HTTPS']) or $_SERVER['HTTPS'] == 'off') ? $wp_content_url : str_replace("http://", "https://", $wp_content_url);

7. Click the blue “Update File” button

Gzipping Preference

Another problem that you would’ve encountered was that your server is not setup for to support php gzipping. By default, Microthemer will try to gzip the Microthemer UI page to speed up loading. When I first loaded the Microthemer UI page on your WordPress install I got an “unsupported compression method” error message. This problem was easy to fix by going to the Microthemer Preferences page and turning off gzipping.

You must login or register to reply to this topic.