TypeError: a.attr(…) is undefined, Cannot read property 'hasClass'

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 7 months, 3 weeks ago.

Author Posts

evgenijgottfried

Hi,

i just run into a problem. Microthemer won’t start up correctly.

TypeError: a.attr(...) is undefined
TypeError: e is undefined (line 1)

Microthemer discovered a JavaScript error on your site:

    Error: TypeError: e is undefined
    URL: /wp-includes/js/wp-auth-check.min.js?ver=5.0.3 (line 1)
    Source: Microthemer interface
wp-auth-check.min.js?ver=5.0.3:1 Uncaught TypeError: Cannot read property 'hasClass' of undefined
    at HTMLDocument.<anonymous> (wp-auth-check.min.js?ver=5.0.3:1)
    at HTMLDocument.dispatch (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3)
    at HTMLDocument.r.handle (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3)
    at Object.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3)
    at Object.a.event.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:9)
    at HTMLDocument.<anonymous> (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3)
    at Function.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:2)
    at a.fn.init.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:2)
    at a.fn.init.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3)
    at Object.<anonymous> (heartbeat.min.js?ver=5.0.3:1)
(anonymous) @ wp-auth-check.min.js?ver=5.0.3:1
dispatch @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3
r.handle @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3
trigger @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3
a.event.trigger @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:9
(anonymous) @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3
each @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:2
each @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:2
trigger @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:3
(anonymous) @ heartbeat.min.js?ver=5.0.3:1
i @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:2
fireWith @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:2
y @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:4
c @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:4
XMLHttpRequest.send (async)
send @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:4
ajax @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.0.3:4
j @ heartbeat.min.js?ver=5.0.3:1
k @ heartbeat.min.js?ver=5.0.3:1
m @ heartbeat.min.js?ver=5.0.3:1
g @ heartbeat.min.js?ver=5.0.3:1
setInterval (async)
d @ heartbeat.min.js?ver=5.0.3:1
d @ heartbeat.min.js?ver=5.0.3:1
(anonymous) @ heartbeat.min.js?ver=5.0.3:1
(anonymous) @ heartbeat.min.js?ver=5.0.3:1

This morning I installed W3 Total Cache and it worked great.
Few hours ago I just wanted to edit some CSS and I forgot to disable that plugin.
I saved the changes and after that this error message showed up and microthemer won’t start up.

I already disabled “W3 Total Cache” and tried to regenerate SCSS within the preferences but nothing worked. Would you help me please? I can send you some Credentials for more insights.


Sebastian

Hey,

Yes I’m happy to help you with this. Please send access details via our secure contact form.

Thanks!
Sebastian


evgenijgottfried

Thank you for your reply. I just send you a message.
I’m looking forward to 🙂


Sebastian

Thank you, I’m looking into this right now.

You must login or register to reply to this topic.