Uncaught TypeError: Cannot read property 'indexOf' of undefined (line 1)

Tagged: 

This topic contains 8 replies, has 3 voices, and was last updated by  Sebastian 1 month, 1 week ago.

Author Posts

CraigPaterson

Hi all,

I seem to be having a JS issue and cannot get to the bottom of it. Just updated MT to the latest version today and it was working fine last time I used it a couple of weeks ago.

Error screengrab – https://d.pr/i/nrHz7V

Hope someone can help.


Nadesignlab

I’m having this issue as well. By chance, are you hosting with SiteGround?


CraigPaterson

@nadesignlab nope, not on SiteGround hosting. It’s at 20i.com


Nadesignlab

Ah, OK. For me, on SiteGround, the fix was to turn off any sort of force HTTPS setting. Not an ideal situation. SiteGround is apparently working on a fix.

Good luck!


Sebastian

@nadesignlab – can I just confirm that you are using version 5.8.2.0 of Microthemer? This release fixed a JavaScript issue another user was having.

If you are already running the latest version, would you mind sending me access for the affected site via our secure contact form? You can use this handy plugin to provide access temporarily without sharing login details: https://en-gb.wordpress.org/plugins/temporary-login-without-password/

Cheers,
Sebastian


CraigPaterson

Hi Sebastian,

Craig here (OP),

I can confirm that I am using the latest version.

I have sent a message via your contact form with login details.

Best,
Craig


Sebastian

Oh silly me, it was the same error but I forgot to actually include the fix in the last update!

I’ve just released the fix now (5.8.2.1) and upgraded you 🙂

Cheers,
Sebastian


CraigPaterson

Awesome Sebastian, thank you very much for your timely response, as always👍🏻


Sebastian

You’re welcome Craig!

You must login or register to reply to this topic.