Uncaught TypeError: cannot read property 'queryselector' of null (line 1)

This topic contains 2 replies, has 2 voices, and was last updated by  Sebastian 4 years, 11 months ago.

Author Posts

razorcool

v5.0.9.4

Chrome browser

Tried to change font color and it worked. Switched to front end, font color stays the same as before change was made. Went back to microthemer mode, it shows “uncaught typeerror: cannot read property ‘queryselector’ of null (line 1)” and the color can’t be changed anymore.


Sebastian

Hey,

Sorry for the trouble. I wasn’t able to replicate this issue on my testing server. Would you mind sending me access details via our secure contact form?

It sounds like it could be a plugin conflict or a malformed selector in MT. Either way, it shouldn’t throw an error. And the styles should save on the frontend. Although that could be a separate caching issue which we can look at if it doesn’t go away with the Uncaught type error fix.

Cheers,
Sebastian


Sebastian

Thanks for providing me with access.

I think the Microthemer issue is caused by some non-ssl resources loading on your site. Microthemer is sometimes useful for illuminating general site errors that also occur outside of Microthemer, as in this case. The uncaught type error is actually coming from the following script:

[your domain name] /wp-content/themes/listingpro/assets/lib/popup/js/modalEffects.js

I think that error might be happening because of the following non https URL on your home page: /wp-content/uploads/2015/11/SabahDiscoveryV4.png

There is also a non-https link to the following stylesheet on admin pages: /wp-content/plugins/listingpro-plugin/assets/css/custom-admin-pages.css

There may be more resources linked to with http:// instead of https:// dotted around your site. Do you think you will be able to locate and update these URLs to https?

Quick tip: I found the above URLs by right-clicking your site, choosing ‘Inspect‘ and then going to the Console tab. This reveals the ‘mixed content’ warnings, and the URLs that produce them.

Cheers,
Sebastian

You must login or register to reply to this topic.