WAMP Server – The server refused the connection. [RESOLVED]

This topic contains 4 replies, has 2 voices, and was last updated by  Sebastian 7 years, 6 months ago.

Author Posts

husterk

I just installed Microthemer on a local copy of my site hosted by WAMP Server. The site loads fine and I can access the WP Admin dashboard. However, every time that I attempt to navigate to the Microthemer dashboard I am simply shown a “The server refused the connection.” error message. I can get to the Microthemer preferences page but not the Microthemer dashboard view so I am not able to edit my site layout. Please help!


Sebastian

Hi there,

It’s possible that this is caused by lack of support for gzip compression on your wamp server. Could you try going to the Microthemer > Preferences page and setting the Gzip option to ‘No’. If that works, we know what is causing the issue. But a preferable option is to enable gzip compression in wamp: http://www.zigpress.com/2009/04/09/enabling-gzip-on-wamp/

Please let me know if that solves your problem.

Thanks,
Sebastian


husterk

Thanks for the quick response. I enabled the deflate_module and headers_module per your instructions and updated the httpd.conf file to allow for GZip compression. Unfortunately this did not resolve the issue. I then disabled GZip on the Microthemer preferences page but that did not help either. Any other suggestions? Are there any log files generated by the Microthemer plugin that I could examine?


husterk

I figured it out! I had to add a trailing “/” to the Frontend preview URL on the Microthemer preferences page. It looks like this may be an issue with Chrome / Microthemer. When I copy and paste the URL from the Frontend Preview URL form input into the Chrome address bar the navigation attempts to append a port number (i.e. :8081) for some reason (maybe something stuck in my cache). By appending the trailing slash it no longer attempts to append the port number and everything works fine.


Sebastian

Brilliant! I’m really glad you managed to sort this. I’m sorry I wasn’t quicker to respond. I was thinking the iframe might have something to do with it, but I wouldn’t have guessed the port number issue. Good work.

Sebastian

You must login or register to reply to this topic.