Why is Microthemer automatically adding position relative? CSS3 Mucks up layout

This topic contains 2 replies, has 2 voices, and was last updated by  rachbriggs 7 years, 6 months ago.

Author Posts

rachbriggs

Notice: this information was written when Microthemer version 2 was current. On Dec 26th, 2014 version 3 was released with a completely new interface. Some of the information may be redundant, but as much of the functionality remains the same in version 3 we haven't deleted this post.

Ok, it took me a while to figure this out. But I can see when I click the “css” link under view site that Microthemer is adding position:relative whenever I apply CSS3 styles to a selector. This messes up my web page layout a bit.

How do I disable it?


Sebastian

In short, you just explicitly set the Position of the selector in question to static (from the dropdown menu) or set CSS3 PIE to “off”. But the reason Microthemer adds this automatically, when CSS3 PIE is “On”, is that position:relative or position:absolute is an often needed hack to make CSS3 PIE work properly.

This issue is explained in the “Microthemer Preferences” Video that can be found here: https://themeover.com/microthemer/demo-videos/

When using CSS3 PIE is not option (but you want your site to look the same in internet explorer, you can normally use a graphics program create a background image. This was discussed in another topic on this forum: https://themeover.com/forum/topic/css3-styles-dont-work-in-internet-explorer/#post-1167


rachbriggs

Understood. I just set the “Position” to “Static” and it worked fine, even in internet explorer. So I guess I just got lucky.

Thanks.

You must login or register to reply to this topic.