Z Index for popup not working [mega-menu covers it]

Tagged: ,

This topic contains 2 replies, has 2 voices, and was last updated by  robertlo 6 years, 7 months ago.

Author Posts

robertlo

See http://gallagher-law-firm.com/pharmaceutical/granuflo-lawsuit/

You’ll see a popup there, but the nav bar is on top of it. I used MT to give a z index of 99999 to the popup using selector div.snp-fb but it did nothing. And also, all of the options under Position in the MT GUI say “Style not applicable” when you hover them. So it’s like that whole section isn’t working.

The plugin is at the latest version. So can you please let me know what I’m doing wrong.

Thanks,
Rob


Sebastian

Hi Robert,

Your Mega Menu plugin adds some CSS code that gives your main menu a really high z-index.

#megaMenu {
    z-index: 999999;
    ...
}

Does Mega Menu allow you to change the z-index via it’s plugin settings? If so, you could try reducing it to e.g. 999.

If not, in order to combat this you need to set an even higher z-index on the dark overlay that covers the page. You can target the overlay using the following selector:

div.fancybox-overlay

Then set z-index to 999999.

You will also need to give the main wrapper for the popup content an even higher z-index than the overlay. You can target the popup using the following selector:

div.fancybox-opened

Then set z-index to 9999991.

That should do it!

Cheers,
Sebastian


robertlo

Ah. You’re right. I forgot that I was using Ubermenu and a long time ago, it was not showing up properly on this old (no longer updated) theme, so I customized its Z index to 999999. But I just remove that from custom css and it fixed it all, and menu is showing fine without it now…

You must login or register to reply to this topic.