April 4th update kills my site.. [RESOLVED]

This topic contains 15 replies, has 3 voices, and was last updated by  nomad411 4 years, 10 months ago.

Author Posts

nomad411

I get this error in the Apache logs:
[:error] PHP Notice: Undefined index: admin_bar_shortcut in /var/www/website/wp-content/plugins/microthemer/tvr-microthemer.php on line 5514

If I remove the plugin, all good, then I bring it bad, breaks. The on screen error message is:

Content Encoding Error
The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.


Abland

Hi, nomad411,

In the admin: Microthemer > Preferences set “Gzip the Microthemer UI page for faster loading:” to No


nomad411

It didn’t help.

Here”s what my admin page looks like: https://www.dropbox.com/s/lhxjhry5h28h7yq/Microthemer_Preferences_%E2%80%B9mysite_%E2%80%94_WordPress.png?dl=0


nomad411

I updated my server earlier today.. here’s the log of it. Do you think it might be the cause?

Start-Date: 2015-04-06 12:27:53
Commandline: apt-get upgrade
Upgrade: libgcrypt11:i386 (1.5.3-2ubuntu4.1, 1.5.3-2ubuntu4.2), gnupg:i386 (1.4.16-1ubuntu2.1, 1.4.16-1ubuntu2.3), gpgv:i386 (1.4.16-1ubuntu2.1, 1.4.16-1ubuntu2.3), libtiff5:i386 (4.0.3-7ubuntu0.1, 4.0.3-7ubuntu0.3)
End-Date: 2015-04-06 12:27:56


Abland

It’s possible with the update – it looks like a php error. What version of php are you running on your server?


nomad411

PHP 5.5.9-1ubuntu4.7


Abland

Strange – the latest version I have is 5.5.21 and no errors. Sounds like an old version issue is back. If you don’t mind helping with a code edit, in micorthemer/includes/tvr-microthemer-preferences.php on line 99 change:

if ($this->preferences[$key] == 0) {
    echo 'checked="checked"';
    $on = 'on';
} else {
    $on = '';
}

to:

if (isset($this->preferences[$key])){
if ($this->preferences[$key] == 0) {
    echo 'checked="checked"';
    $on = 'on';
} else {
    $on = '';
}
}

I can’t replicate on my version but see if this removes the one error.


Abland

I should add – don’t make any changes you are uncomfortable with or unsure of. I know Sebastian is always ready to help by logging in with your permission for a closer look.


nomad411

No difference…

I just checked and another website on the same server is fine. Must be a plugin conflict..

I’ll go test that and report later either way.

Thanks


Abland

Thanks for testing out the code – let me know what you find out. I’m interested to know 🙂


nomad411

Turning off all plugins didn’t help.

I also tried switching to another theme, TwentyFifteen. it was better but with errors showing as well.

I’d love to take you up on the remote help offer, I’m sure you’re much better at this than me..

How do we proceed?


Abland

Sebastian has a secure contact form to send access info. Having admin access, or temp admin access to your site would be the place to start. Let him know it’s about this forum post.
https://themeover.com/support/contact/

But I wondered if you have an earlier version, remove the plugin completely and revert to that earlier version and see if the errors go away. If they do, try reinstalling the new version again
– or just try reinstalling the new version.
It’s possible the installation corrupted and a clean install will fix it.


nomad411

Great idea.

I just deleted 3.4.7 and put on V 3.4.1 and all is fine.. 🙂

I’ll let Sebastian know then and ask how he’d like to proceed.


Sebastian

Hi there,

I’m really sorry for the bother. There was an error in version 3.4.4 and 3.4.7. I’ve fixed the issue and released an update – version 3.4.9. You should be able to update to this via your WordPress dashboard now.

I neglected to consider that some PHP variables could be undefined for users that are upgrading when I added the option to include a link to Microthemer in the WP admin toolbar. I believe version 3.4.9 will resolve the errors you were seeing. Please let me know if everything is OK at your end.

Thanks,
Sebastian


Sebastian

ps Thanks for helping out Abland 🙂


nomad411

Beautiful!

Upgraded and works as expected 🙂

Thanks a lot

You must login or register to reply to this topic.