Autoptimize compatibility [error on loading RESOLVED]

This topic contains 6 replies, has 2 voices, and was last updated by  Sebastian 6 years, 9 months ago.

Author Posts

ErikHaagensen

Hello,
I’m a brand new user and just installed Microthemer on haagenstuff.com and tried to use it. There was an error and I read that CSS minification plugins can cause problems and also read that Autoptimize definitely caused a problem for another user.
Is there an alternative CSS minification plugin I could use? Or some particular workflow to use Autoptimize and Microthemer together?
Perhaps I could disable Autoptimize while working with Microthemer and then re-enable it after? I hate to have to give up the benefits of Autoptimize in order to enjoy Microthemer.
Thanks for your help,
Erik Haagensen


Sebastian

Hi Erik,

There are a couple of options available. One is temporarily disabling autoptimize while you work in Microthemer as you say. Another option would be using w3 total cache or super cache instead. Or you could
Just disable the option in autoptimize for deferring loading of CSS/JavaScript. I think that was the option that caused issues for another user.

I’m travelling all day today and providing support from my phone. Which means I’m slightly limited in what I can do. I can check the plugin tomorrow if you’re still stuck?

Cheers,
Sebastian


ErikHaagensen

Hi Sebastian,
Thank you for your quick response.
I had previously tried those other two plug-ins and had issues with them on one site. Autoptimize has not created any problems for me until now so I have preferred it. Also, I use Siteground for hosting, they have their own caching plugin, so Autoptimize is nice because it just does the minification and does not conflict with Siteground’s CachePress.
In Autoptimize I do not have the deferred loading selected, I just use the simple settings and check the main box for HTML, CSS, and Javascript. When you look at the advanced settings it seems to default to NOT inlining/deferring CSS.
It would be great if the conflict with Autoptimize could be easily resolved, if not, I guess I will look to the workaround or re-examine the alternatives you mention and looking at how to configure them to not conflict with Siteground CachePress.
Thank you,
Erik


Sebastian

Hey Erik,

I was recently advising another customer to try w3 total cache with just the minification and concatenation options enabled. I too find that enabling all the options in optimization plugins tends to break things for site visitors, and that this is sometimes easy to miss from a logged-in admin’s perspective.

I’d also be happy to troubleshoot the Autoptimize issue on your specific install if you would like to send me access details via this secure contact form: https://themeover.com/support/contact/

Cheers,
Sebastian


Sebastian

Thanks for sending login details Erik, I’ve now released an updated version of Microthemer (4.7.1) that fixes the compatibility issue with Autoptimize.


ErikHaagensen

Thanks Sebastian, what great service & support!

I updated the plugin, removed the temporary fix of excluding active-styles.css in Autoptimize, and confirmed that the new plugin version was working fine without the exclusion.

Now I have no excuses not to finish off the site and start selling pottery!


Sebastian

You’re welcome Erik, all the best with your pottery. And many thanks for the review on wordpress.org!

You must login or register to reply to this topic.