Microthemer Refusing to Save Settings on Child Sites (Multisite)

This topic contains 7 replies, has 3 voices, and was last updated by  Sebastian 1 year, 11 months ago.

Author Posts

kamarch

I’ve tried:

– going into phpmyadmin to force the database to read the site url’s as https
– forcing the server to read SSL
– changing /wp-content/plugins/microthemer to 0755
– applying SSL to the htacess and restarting apache
– disabling potentially conflicting plugins (all plugins currently used are working fine on other server)

I created a user with super admin privileges along with our webmin (cpanel)

There’s also a constant refresh and add to cart bug happening with bookingwp.com’s WooCommerce Appointments

Let me know how we can fix this since it’s really causing some major delays


kamarch

Here’s an error:

Script error. (line 0)
Microthemer discovered a JavaScript error on your site:

Error: Script error.
URL: (line 0)
Source: Microthemer interface

Sebastian

Hey,

Sorry to hear that you’ve encountered these issues. Please could you send me access details for your install via our secure contact form so I can troubleshoot this?

Many thanks,
Sebastian


Abland

Hi, @kamarch

Are the child sites not opening in the interface at all? Or they do but any changes are not saving?

If you are mapping domains that can be an issue depending how you map them. I used the mapping plugin which directs the domain properly, but in the admin the site and home url of the child sites in wordpress were still the subdirectory and that’s what was giving me issues at one time. Once I changed those to match the mapped tld it worked.


Sebastian

It could also be due to a recent update that was designed to improve compatibility with certain multi-site configs, but may have had unexpected side-effects for your install. If the error popped up spontaneously in the last few days that scenario seems likely. I will know for sure once I’ve inspected the URLs Microthemer is generating on your site.


kamarch

Hi @arland,

I do have domain mapping as well as an admin uri mapping but neither conflicted with Microthemer before. I’ll try to take a look around.

@sebastian

I’ll be sure to hop on the secure form to do so. I honestly forgot where it was lol.


kamarch

Sorry for the delay @sebastian, email with credentials has been sent.


Sebastian

For anyone following this thread, Abland’s solution on this other thread did the trick for @kamarch too.

Thanks @abland!

You must login or register to reply to this topic.