Mycrothmer not loading on HTTPS sites [mixed content error]

This topic contains 3 replies, has 2 voices, and was last updated by  Sebastian 6 years, 6 months ago.

Author Posts

sebastiangrede

Hi,
I just set up an SSL certificate for my online shop (woo commerce). I am using WordPress HTTPS to make sure all elements on the checkout and account pages are transmitted via https.
When I activate “force secure checkout” or force the relevant pages to be https with the WordPress https plugin, microthemer won’t load these pages anymore.
First I got an error saying a security block is keeping it from loading a cross-platform configuration. I turned off the plugins and could load the pages again. After turning on the https wordpress plugin/force secure chekcout again the relevant sites won’t load but the error is gone.

Kind Regards
Sebastian


Sebastian

Hey Sebastian,

You need consistent http or https between the Microthemer UI and frontend in order for things to work. So you have two choices as far as I can see:

  • Make your entire site https. This is what Google recommends. And the performance hit theory of full site SSL is a myth (also according to Google)
  • If the above option isn’t workable for some reason, you may have to temporarily disable the SSL plugin while you work in Microthemer. Or, if you have a local copy of your site, do the style changes in Microthemer their and then export your MT settings to the live site.

Cheers,
Sebastian


sebastiangrede

Hi Sebastian,
thanks for your supply. Ist it enought if i make the whole admin area https? So that the interfacing is consitent with the https page that needs to be displayed?

Regards
Sebastian


Sebastian

I suspect that making the admin area https will solve the issue of styling the https frontend pages on your site. But you will probably get errors when trying to style http frontend pages. Do you have a good reason not to go full site SSL?

You must login or register to reply to this topic.